Intermittent email delivery delays
Incident Report for AchieveIt
Resolved
The Mailgun service appears to have stabilized. During the past 12 hours, all emails sent from our system through Mailgun have been delivered as expected. We are marking our issue as resolved, and will provide additional updates from Mailgun if there are any of importance to our customers.
Posted Feb 23, 2023 - 21:21 EST
Monitoring
Mailgun continues to be under an active DDoS attack. We have observed improvements in email delivery rates over the past 24 hours which indicates that Mailgun's mitigation efforts are being effective. We will continue to monitor delivery rates and Mailgun reports for the immediate future and provide updates when there is a substantial change.
Posted Feb 23, 2023 - 10:56 EST
Identified
The email service used by AchieveIt to send emails from our production applications is experiencing intermittent delays delivery certain emails to recipients. The service, Mailgun, has reported that they have been under a distributed denial of service attack since February 21, 2023. During that time, Mailgun has been working with its hosting and infrastructure providers to reduce the impact of the attack and restore normal delivery.

We have observed that a small percentage of emails from AchieveIt in the past 36 hours have been either delayed or not yet delivered. Most emails are, however, being delivered as expected. We will continue to monitor Mailgun's response and provide updates here. We are also evaluating options for delivering the remainder of the delayed emails.
Posted Feb 22, 2023 - 16:34 EST
This incident affected: Web Application - Commercial Environment and Web Application - US Government Environment.