Intermittent Connectivity Issues
Incident Report for AchieveIt
Resolved
As of 21:36 UTC (5:36 PM EDT), Microsoft has reported that it has mitigated the performance degradation on its CDN services. We have observed that AchieveIt application behavior has returned to normal. We will continue to monitor system performance, but we believe the issue is now resolved.
Posted Jul 12, 2021 - 19:52 EDT
Identified
Our hosting provider, Microsoft Azure, is experiencing a degradation of their content delivery network (CDN) service that is affecting some AchieveIt users. AchieveIt uses the Azure CDN to serve the static web content for our web application. A user who is affected by this incident may experience the AchieveIt application loading slowly or sometimes timing out. You may be able to temporarily resolve the connection problem by refreshing the web application in your browser or retrying the action that timed out.

We will continue to monitor and provide updates as Microsoft works to resolve the problem.
Posted Jul 12, 2021 - 15:40 EDT
This incident affected: Web Application - Commercial Environment and Web Application - US Government Environment.