Email delivery is delayed
Incident Report for AchieveIt
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 12:58 EDT
Update
We have verified that email flow has been completely restored and all delayed emails have either been delivered or are in the process of being delivered.
Posted Jun 09, 2022 - 12:57 EDT
Update
Mailgun has confirmed that they have restored all services but are still seeing delays in delivering emails. We are seeing many emails being successfully delivered, but it is likely that some emails are also being delayed. All delayed emails will be delivered once Mailgun resolves their system problem.
Posted Jun 09, 2022 - 10:09 EDT
Monitoring
Mailgun has at least partially resolved their system outage and we are beginning to see emails flow again. We will continue to monitor to ensure that emails continue to be delivered as expected and post an update soon.
Posted Jun 09, 2022 - 09:46 EDT
Identified
The service that AchieveIt uses to send emails from our platform, Mailgun, is experiencing a service interruption that is causing emails sent from our system to be delayed. We are monitoring Mailgun's updates as they work toward a fix and will publish updates here as we know more. Any email that should be sent will still be delivered once the email service has been restored.
Posted Jun 09, 2022 - 09:08 EDT
This incident affected: Web Application - Commercial Environment and Web Application - US Government Environment.